Application crashes when using swc with elements that are set to visible=false in flash professional cs5.5 properties window

Jngrt's Avatar

Jngrt

07 Mar, 2012 02:58 PM

Strange crash. I found a work-around, not a solution.

Using swc from flash professional cs5.5. When I instantiate library symbols from this swc in my robotlegs 1.5.2 app, with flex 4.6 and air3, the application kept crashing. Debugging showed that the library symbols where instantiated, but all of its properties where "null". It is possible to instantiate library symbols before i create the robotlegs context, even after i've set up all commands and models, but somewhere while loading all my views something goes wrong and the app freezes.

After much trial and error i noticed a sprite in the fla file which I temporarily didn't need, for which i unchecked the "display" property (this is new in cs5.5). With this unchecked the problems occur. With this property checked everything is fine.

So, not a real showstopper, since there are other ways to temporarily disable things (alpha=0 or off stage). However it can be quite annoying if you don't know what causes these crashes, and there are no clear causes for a crash and no clear messages to indicate what's wrong.

Speculations on what's causing it: Since it only goes awry after a certain point, i guess that flash cs5.5 sets some kind of metadata for these items. And this might conflict with swiftsuspenders metadata...

  1. Support Staff 2 Posted by Ondina D.F. on 10 Mar, 2012 12:32 PM

    Ondina D.F.'s Avatar

    Thanks for sharing.
    I'll move this to Solutions even if it's not a solution;)

  2. Ondina D.F. closed this discussion on 05 May, 2012 01:24 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac